Degraded performance of analytics services

Incident Report for Gorgias

Resolved

This incident has been resolved.
Posted Jun 29, 2026 - 16:59 UTC

Monitoring

The root cause was addressed and we are currently monitoring the services.
Posted Jun 29, 2026 - 16:32 UTC

Identified

Due to a traffic spike, some customers might experience long loading times for analytics. We have identified the root cause and pushed a fix. If you still experience issues, you should try reloading the application in the browser.
Posted Jun 29, 2026 - 16:03 UTC